Issue - O2 sensor voltage at idle + knock sensor

Post here where your issue is not tuning specific but more of a sensor or mechanical issue
Post Reply
Stoil
Posts: 4
Joined: Sun Jul 01, 2018 10:57 pm

Issue - O2 sensor voltage at idle + knock sensor

Post by Stoil » Mon Jan 07, 2019 2:16 am

Hi all,

I am building a S13 EUDM with a sr20det black top from a S14 zenki jdm version. ECU Type: WH 23710 75F00
Recently i have installed a new pro wiring harness from wiring specialties. The problems appeared before the wiring installation, so i thought i have a crappy wiring.

Before i install my type 2 board i want to bring the engine to stock settings.
I have a weird problem at idle, the engine O2 sensor is showing values unter 0.2 Volts. Are these values normal? I have been told that the value should be between 0.6 - 0.8 Volts. O2 sensor (thick version) is brand new. (csv attached)

- 1539_30 csv table is driving on first gear inside a garage
- 1507_29 csv table is car idling and standing

I am getting also a fault code 34 knock sensor. My knock sensor is brand new and the wiring to the ecu too. I have checked the wiring for continuity and also the pin numbers.

Could you please help. Thanks. :)
Attachments
NIStune_2019-01-04_1539_30.csv
(235.66 KiB) Downloaded 19 times
NIStune_2019-01-04_1507_29.csv
(76.38 KiB) Downloaded 15 times

Stoil
Posts: 4
Joined: Sun Jul 01, 2018 10:57 pm

Re: Issue - O2 sensor voltage at idle + knock sensor

Post by Stoil » Mon May 06, 2019 10:12 pm

hi all,

I have solved the issue with my car. 8)
It was a very complex problem:
1. Check your MAF. (mine was dying)
2. Set ignition timing using a timing light. (see service manual)
3. Set base fuel pressure. (see service manual)
4. Check for leaks and set your boost pressure.
5. Buy a o2 wideband sensor. Narrowband O2 sensor can't give a steady reading by design.

Post Reply