hcr32 rb20for25 vct question

Nistune topics related specifically to the 6303 cpu

Moderator: Matt

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

hcr32 rb20for25 vct question

Post by r324u » Mon Jul 29, 2019 4:09 am

I recently had the ecu pinned bridging the a/c 9 to pin 113 to activate the vct on my rb25det neo, I have it successfully activating( cut) @ 1100 and recover at 5900, my questions is that on the consult view the vct never shows it activating even though mechanically it will with no issue, not sure if there is something else I need to do, I tried to search and read about it but haven't found anything pointing in the right direction to get

Thank you! :P

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Mon Jul 29, 2019 11:26 am

The same code is used from what I can see for the LED, AC and VFP versions of firmware

It should work with the latest firmware, but older firmware versions may not show it in stream mode, after I noticed an extra fix was added to original version of AC firmware

Code: Select all

rem VTC consult routine
rem Fix problem with stream mode not reporting VTC
rem AC61		AC61_Set_BitRegs:
rem AC61 : 7F 00 DB 	clr	00DB_Reg_2_Digital_Control_2

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Mon Jul 29, 2019 12:10 pm

I believe I am running the latest firmware, I am going to try and start fresh and just copy over my tune, maybe that will help, Worse case it works and the light doesn't activate no big deal, thank you for your quick reply as always. I am loving the new gauges and such!

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Wed Jul 31, 2019 11:26 am

I've just flashed an R32 ECU with the latest VCT AC ENT file from the ROM pack, and both the AC output and VCT indicator seem to be working as expected. See image
2019-07-31 09_51_08-Nistune [HCR32 SKYLINE (RB20DET) Feature Pack 1.0.png
2019-07-31 09_51_08-Nistune [HCR32 SKYLINE (RB20DET) Feature Pack 1.0.png (232.06 KiB) Viewed 399 times

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Wed Jul 31, 2019 12:18 pm

ok I verified I have latest and I still don’t get it to light up, it clicks but does not light up ?

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Wed Jul 31, 2019 12:27 pm

Latest firmware on the board?
A31_FOR_RB25_11U00_74L0F_TPS_VCT_ACOUT_v5_FP.ent dated 15/10/18?

I just tried it then so I can confirm software (1.3.5) and firmware (attached) are fine
Attachments
A31_FOR_RB25_11U00_74L0F_TPS_VCT_ACOUT_v5_FP.zip
(19.58 KiB) Downloaded 12 times

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Wed Jul 31, 2019 12:28 pm

Also make sure in Consult Channels Digital Control register 1,2 and 3 are enabled. If older firmware, reflash the board with what I attached

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Wed Jul 31, 2019 1:08 pm

the a31 file for rb25 will work on my hcr32?

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Wed Jul 31, 2019 1:39 pm

Matt wrote:
Wed Jul 31, 2019 12:28 pm
Also make sure in Consult Channels Digital Control register 1,2 and 3 are enabled. If older firmware, reflash the board with what I attached

what exactly do you mean enabled ? where do I do that?

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Thu Aug 01, 2019 2:26 pm

I have the board setup for ac out, light still doesn’t work I am going to send it back to the distributor and have him flash it again.
Attachments
009A180D-F672-4AFD-9E08-CD8A504660EF.jpeg
009A180D-F672-4AFD-9E08-CD8A504660EF.jpeg (2.76 MiB) Viewed 382 times

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Sat Aug 03, 2019 1:28 am

Digital register 1,2,3 are in channels ticked when you first connect (refer software users manual) [Consult register list]

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Sat Aug 03, 2019 1:59 pm

So i did make sure all those channels are ticked when i connect, vct still activates but their is no light, im guessing i have to get my board re-flashed??

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Sat Aug 03, 2019 2:20 pm

Yeah seems like it, if you are concerned about the indicator not showing on the screen. Both in tuner and stream modes?

r324u
Posts: 22
Joined: Tue Jul 11, 2017 11:20 am

Re: hcr32 rb20for25 vct question

Post by r324u » Sat Aug 03, 2019 2:59 pm

nope it wont show in either, I have two boards swapped one another out and neither would work. I had them flashed around august 2018, do you know if the fix was after this or before it, just curious thank you for your help

Matt
Site Admin
Posts: 8633
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: hcr32 rb20for25 vct question

Post by Matt » Tue Aug 06, 2019 9:58 am

Fix was before this, but latest file version was Oct 2018

Post Reply