Timing issues

Nistune topics related specifically to the 6303 cpu

Moderator: Matt

Matt
Site Admin
Posts: 8219
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Timing issues

Post by Matt » Wed Oct 22, 2014 5:45 pm

I may not be able to fix the Consult reporting when in/out of gear. This is something Nissan consult reports to us. I provide the ability to report the consult values, but it appears they are not correct when at idle (ie 5 deg BDTC out) since you have confirmed the table values are now correct

Idle timing maps are referenced when in gear/neutral

Injector size - I used the same values as Z32. If you can confirm the M30 is 180CC (this seems very low, I would expect 200CC at a minimum same as RB30E) then I can update it

my1path
Posts: 41
Joined: Fri Apr 06, 2012 8:06 am
Location: Southern CA, USA

Re: Timing issues

Post by my1path » Thu Oct 23, 2014 12:25 am

Ok, I think I can live with a minor reporting discrepancy since I know that it is really doing what the map says and not what Consult reports.
Matt wrote:I may not be able to fix the Consult reporting when in/out of gear. This is something Nissan consult reports to us. I provide the ability to report the consult values, but it appears they are not correct when at idle (ie 5 deg BDTC out) since you have confirmed the table values are now correct

Idle timing maps are referenced when in gear/neutral

Injector size - I used the same values as Z32. If you can confirm the M30 is 180CC (this seems very low, I would expect 200CC at a minimum same as RB30E) then I can update it
The M30 was an NA Single Overhead Cam VG30E like the NA Z31, 85–94 Maxima and 90-95 & 96-00 Pathfinder(Presently I am running the 96-00 Pathfinder Injectors). The Turbo motors came with 260cc But the NA motors came with 180cc.

If I can find my test results from my injector cleaning a few years ago I will share it. In the mean time I did find this:
Z31_VG30_128_E_86 wrote:#ENGINE SPECIFIC PARAMETERS
CYLINDER=6
INJECTORCC=185
ENGINECC=3000
EMULATOR_OFFSET=&HC000
J30_VG30_256_E wrote:#ENGINE SPECIFIC PARAMETERS
CYLINDER=6
ENGINECC=3000
INJECTORCC=185

Matt
Site Admin
Posts: 8219
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Timing issues

Post by Matt » Thu Oct 23, 2014 9:25 pm

Thanks. I've updated it. Only used for the resize option

my1path
Posts: 41
Joined: Fri Apr 06, 2012 8:06 am
Location: Southern CA, USA

Re: Timing issues

Post by my1path » Wed May 06, 2015 4:19 am

I found this on an older thread. I'm going to add it to the file and see If I can get any closer to my actual Idle numbers. I will report back with all my offsets so they can be included with future updates.
viewtopic.php?f=8&t=588
IDLE_TIMING_MAP_OFFSET=
EDIT: Nope, 0, 5, 10, -5, no effect on reported Idle timing.
The other settings work fine;

CONSULT_TIMING_OFFSET=45
TIMING_MAP_OFFSET=5

Matt
Site Admin
Posts: 8219
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Timing issues

Post by Matt » Thu May 07, 2015 6:20 pm

Did you view Idle timing map in 'filtered' rather than 'raw' mode?

my1path
Posts: 41
Joined: Fri Apr 06, 2012 8:06 am
Location: Southern CA, USA

Re: Timing issues

Post by my1path » Thu May 07, 2015 11:44 pm

This is in reference to Reported timing in the consult window view vs actual timing.
But I guess you're right, that modifier line would affect the map view and not the consult view.
It says [RAW] on the top of the Idle map window(I don't see a drop down for filtered views) and the reported timing Still becomes correct when I get into the regular timing map.


EDIT: found it by right clicking. I'm gonna try some things I'll get back to you.

Howlermonkey
Posts: 6
Joined: Sun Mar 22, 2009 4:11 am
Location: west palm beach
Contact:

Re: Timing issues

Post by Howlermonkey » Mon Oct 24, 2016 9:33 am

I know this an old thread but want to confirm the 180cc injectors.

It's also possible that the "temp enrich" has to do with a fuel temp sensor mounted in the fpr and that over a certain fuel temp, it enriches to combat vapor lock and is mostly used during a start after a hot soak.

300zx single cam vg30e had the same thing.

I may be mistaken about thier term "temp enrich" usage but i do know nissan did use a fuel temp sensor......just not sure if this is where it's used.

Matt
Site Admin
Posts: 8219
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Timing issues

Post by Matt » Mon Oct 24, 2016 10:29 am

Thanks for confirming the injectors

There is the possibility some of the temperature tables use the fuel temp as input (rather than coolant temp) but would need to check the code to verify the indexing

Matt
Site Admin
Posts: 8219
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Timing issues

Post by Matt » Thu Sep 27, 2018 12:37 pm

Just an update
CLOSED_LOOP_TABLE_TPS_MAX is actually the ADD_FUEL table location (used to access last column in fuel map on full throttle, M30 ECU code slightly different from other models)

Updated for next release

Post Reply