RPM Drops and car runs lean when holding at 2k rpm

Nistune topics specific to the 6802 cpu

Moderator: Matt

Post Reply
ff7f00
Posts: 1
Joined: Sat Jun 24, 2017 4:59 am

RPM Drops and car runs lean when holding at 2k rpm

Post by ff7f00 » Tue Jul 16, 2019 7:23 am

Hi all,

I was following along with this diagnostic flowchart in the FSM for a 1990 240sx KA24E that asks you to rev the engine at 2k rpm and look at the ECU:

Image

When doing this, the engine will stay at 2k when the LED on the ECU is solid green and will drop and go lean when the light turns off. Here is a video of that in action

https://www.youtube.com/watch?v=9ArY4Cf ... e=youtu.be

The AFR when the light is solid green isn't great at the moment (hovers around 16/17 AFR) but the PLX shows LEAN when that light turns off.

Does anyone know what that LED is indicating in this scenario? (the flowchart in the FSM doesn't do a great job explaining that)

I've checked for ECU fault codes by switching to the fault code diagnostic mode on the ECU and there are none at the moment (also no error codes or warnings in Consult in the Nistune view)

Matt
Site Admin
Posts: 8222
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: RPM Drops and car runs lean when holding at 2k rpm

Post by Matt » Mon Jul 22, 2019 6:38 pm

There are different modes depending on screw position

There is an AFR mode which flashes (or may be solid) lean which is green.... rich is RED

Also diagnostic mode will flash codes using GREEN/RED for tens/units for example 13 (1 flash, 3 flashes)

Not sure what is going on with that. I guess when did the problem start happening, any changes etc?

Post Reply