Wideband AEM Failsafe 30-4900 connection

Anything related to the AEM brand of wideband devices.

Moderator: Matt

Shane001
Posts: 9
Joined: Mon Jul 24, 2017 2:32 pm

Re: Wideband AEM Failsafe 30-4900 connection

Post by Shane001 » Sun Nov 08, 2020 9:04 pm

Well I spent most of this afternoon trying to figure out why this wasn't working. Then I did some research on com0com and the AEM WBFS Bridge software....

So it turns out you do not use the DLP for this method. You do use the USB connection from the AEM gauge.

For anyone else wanting to do this, the AEM WBFS Bridge was developed by the Evo community to log the AFR signal from this gauge. The bridge software basically converts the data from the USB cable to a serial/COM output signal. com0com then basically duplicates this signal to another com port number that can then be used with Nistune (or other software).

So for the method above, all you do is plug the USB cable from the gauge into your computer, run the bridge software selecting either of the two com port numbers from com0com, then run Nistune and configure the AEM wideband to use the other com port number.

The downside to this option is that it does not log boost. AFR/Lambda only.

Matt
Site Admin
Posts: 8612
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Wideband AEM Failsafe 30-4900 connection

Post by Matt » Mon Dec 14, 2020 10:54 pm

Found an issue from logs, that another customer emailed through

Problem appears to be that the data gets out of sync. So we are looking for say “14.7\r\n” but then the data stream gets messed up and is seen like ” \n14.7\r”. I’ve put an update in a beta version tonight 1.3.32. That should fix it

Post Reply