SR20DET Ignition Timing Jumping

Post here where your issue is not tuning specific but more of a sensor or mechanical issue
Post Reply
JDMS13Silvia
Posts: 1
Joined: Tue Jun 12, 2018 6:57 am

SR20DET Ignition Timing Jumping

Post by JDMS13Silvia » Wed May 12, 2021 2:10 pm

I have been troubleshooting this issue for a while now and am at the point to reach out for some advice.

The Issue:
When setting my ignition timing to 15 degrees, it "randomly" jumps up or down, and tends to get worse as the car warms up. AFR bounces around worse as it gets warmer (13-17)

The Vehicle:
1991 Nissan 180sx SR20DET
Tomei 270 Procams
550cc Subaru Yellow injectors (Flow matched, tested, new rings)
Walbro 255 Fuel pump (8-10 years old)
(unknown) FPR set to 43psi
Z32 maf
Turbonetics T3 60 turbocharger
Phase 2 Motorsports Ignition Coils
Wiring Specialities Ignition coil harness
RS Enthalpy tune on Nistune board

What I've already tried:
-Mechanical Timing is spot on
-Replaced old fuel
-Changed spark plugs to BKR7E from BKR6E
-Set tps
-Set fuel pressure
-Replaced all vacuum lines
-Boost leak test
-Compression test (+120 across the board)
-Leakdown test (less then 20% loss)


I have attached a log I took, if there is anything else I should have checked off to record let me know as I am inexperienced but learning with the software. Owned this car for 11 years, so this wasn't a problem inherited. Cams, injectors, turbo, MAF, ignition coils and ecu were most recently installed. Anything helps, thanks!
Attachments
Nistune_2021-05-11_1854_15.csv
(450.47 KiB) Downloaded 8 times

Matt
Site Admin
Posts: 8700
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: SR20DET Ignition Timing Jumping

Post by Matt » Fri May 14, 2021 10:19 pm

Training notes. See page 23:
https://www.nistune.com/docs/Workshop%2 ... 0Notes.pdf

Idle timing runs in closed loop. It looks at the target RPM table, and the adjusts AAC (not in the log) and ignition timing to achive this.

Idle stablisation max/min tables are used in addition to advance/retard tables as a reference.

Yours seems to go from 15 down to 9 however. Does the AAC work okay? No maps posted, so compare all your maps against factory and see what is changed in the tune

Idle/decel are used outside closed loop (like deceleration, or coasting in neutral) which is when those tables are referenced. Shouldn't affect AFRs?

Injection time sits around 2.12 - 2.18ms in the whole 5 mins of the log

Post Reply