Bad idle after 3000rpm

Post here where your issue is not tuning specific but more of a sensor or mechanical issue
Post Reply
Marko1600
Posts: 4
Joined: Fri May 15, 2020 10:15 pm

Bad idle after 3000rpm

Post by Marko1600 » Mon May 18, 2020 11:52 am

Hi all,

After some clues on a problem I am having with S14 SR20det in a Datsun 1600...

After many issues I have got engine running ok with all readings showing correct on Consult...

Idle is good
No vac leaks I can find (have tested)

Issue is - when I increase rpm gently all seems ok and settles back to normal idle

As soon as I hit about 3000RPM engine returns to idle and almost stalls but then goes to a lumpy idle and runs very rich..

On log file seems timing drops to about 9-11deg and fuel increases to about 7ms

Turn off, restart and all fine again until open throttle to 3000rpm again...

Checked with data scan and no fault codes show up...

Any clues???

Matt
Site Admin
Posts: 8432
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Bad idle after 3000rpm

Post by Matt » Tue May 19, 2020 10:19 am

You won't get fault codes unless a sensor has gone bad (short/open loop). What MAF / injectors are you running? When did the problem start happening?

Marko1600
Posts: 4
Joined: Fri May 15, 2020 10:15 pm

Re: Bad idle after 3000rpm

Post by Marko1600 » Tue May 19, 2020 7:48 pm

Hi Matt,

You helped me sort out MAF issue afew weeks ago by email...

Had wiring back to front!!!

Z32 MAF
550cc injectors
Pete sent me the ECU with a tune for this in it...


Now all is reading good in Nistune as per your advice and specs...

Since then, starts, idles, not rich but when throttle hits about 3000k and back off it bogs to almost stall then goes to weird idle and starts running rich...

Cheers

Matt
Site Admin
Posts: 8432
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Bad idle after 3000rpm

Post by Matt » Fri May 22, 2020 11:35 am

You will need to post the log file showing what is going on and we can look at that. So take a consult log with default parameters and post it here

Marko1600
Posts: 4
Joined: Fri May 15, 2020 10:15 pm

Re: Bad idle after 3000rpm

Post by Marko1600 » Sat May 30, 2020 6:09 pm

Hi Matt,

Sorry was looking into a few things so couldn't get a log file.

I have just generated a log file for you to look at.

Let me know if there is anything obvious to you.
Attachments
Nistune_2020-05-30_1657_02.csv
(80.22 KiB) Downloaded 3 times

Matt
Site Admin
Posts: 8432
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Bad idle after 3000rpm

Post by Matt » Sun May 31, 2020 12:32 pm

Similar issue to here:
viewtopic.php?f=8&p=27659

Once you rev it high at 3000rpm your turbo seems to start spinning, and you can see the MAF (blue line) holding up high even though RPMs (red) from 39 seconds in the log drop quicly

We then see the calculated load (purple) and injectoin time (green) rise from 40 seconds onwards

It only happens once you get the turbo spinning hard enough. Have a look at what I wrote there. Main thing is to try and pull fuel out the bottom RHS corner of the map from a tuning point of view to reduce the overfueling
Attachments
2020-05-31 10_57_09-Nistune.png
2020-05-31 10_57_09-Nistune.png (53.36 KiB) Viewed 108 times

Matt
Site Admin
Posts: 8432
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Bad idle after 3000rpm

Post by Matt » Sun May 31, 2020 12:34 pm

Also your idle at 43 seconds is the same as 34 seconds... the same MAF readings (1.5V is a bit high? Should normally be about a volt) and also same injection time

Check you don't have an idle airleak, since it shouldn't be around 1100rpm normally, but it is cold (29degC) so might be idling high whilst cold. When at 80degC coolant temp should be about 800rpm idle normally and the MAF voltage might be lower then

Marko1600
Posts: 4
Joined: Fri May 15, 2020 10:15 pm

Re: Bad idle after 3000rpm

Post by Marko1600 » Sun May 31, 2020 10:38 pm

Thanks for the response Matt...

I read the post and kind of get the issue of air being pulled through by the turbo....

I have also checked and located an air leak at the #4 injector insulator on manifold - so will need to pull fuel rail and re seat / replace insulator grommets I think..

Not sure though how to go about pulling fuel out at the points you mentioned☹️☹️

Will re read manual and see if I can work it out...

Otherwise - not sure what to do until I send for a final tune - just trying to get right for engineering purposes first!!!

Matt
Site Admin
Posts: 8432
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Bad idle after 3000rpm

Post by Matt » Mon Jun 01, 2020 1:39 pm

Pull the numbers into the negative values (filtered mode) in the area of the fuel map where it is overfueling

You can also try lowering TP max table in the lower RPM areas to limit maximum injection

Post Reply