Start tuning SR20DET

Discussions concerning the M7790 cpu

Moderator: Matt

Post Reply
kamilp1908
Posts: 12
Joined: Wed Oct 23, 2019 5:46 am

Start tuning SR20DET

Post by kamilp1908 » Mon Apr 05, 2021 3:24 am

Engine spec:
SR20DET JDM
GTX28
Hks Cams 256/260
Subaru 440ccm
Z32 MAF

I changed INJ (adjusted Load max and crank table, didn't change Load scales), then MAF (didn't change load scales). O2 sensor turned off. AFR sensor in tail pipe.
I updated inj latency to 770us. Changed K konst to 39100. With this setup I had AFR around 14.7 on idle.
I made some cruising runs 4/5th gear (2.5k-2.8k). I got AFR around 14.5ish. Looked nice.

But when I started to analise log I have found 2 problems (???):
1. After gear change AFR rises to 16.2 then drops to 11.5, but it goes to 14.5 (it takes about 1.5sec from rich to normal)
2. At 5th gear at 2.6k rpm I have TP 19 (AFR 14.2), but Min Load for this rpm is 25.

My questions:
1. Is it normal to AFR behave as like this after gear change?
2. Which TP value ECU uses to calc injector time?

Maybe my problems are connected with not changing load scale during MAF/INJ changes.

Log file recorded crusing from 3rd to 5th gear (about 2.5k-2.6k rpm)
Attachments
Nistune_2021-03-14_1115_40.csv
Crusing from 3rd to 5th gear
(221.96 KiB) Downloaded 9 times
Nissan14.04.2021_cruise_K_OK.bin
Current ECU bin
(32 KiB) Downloaded 7 times

Matt
Site Admin
Posts: 8675
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Start tuning SR20DET

Post by Matt » Mon Apr 19, 2021 9:56 am

When you change gears, we see the MAF voltage drop (no load), so TP and injection time drop accordingly

We see about 15-16 AFR on decel, but then when you get the increase in load it seems like it takes a while for the wideband to register.

16:907 we have 14.7:1 AFR (4.37ms injection time)
17.891 we have 16.5:1 AFR (4.57 ms injection time)

Do you 'feel' a lag with acceleration at this point, where it affects drivability?

It's a bit strange how it goes lean, then slightly richer 14.96 (at 18.079) and then lean again before going rich
Attachments
2021-04-19 08_21_15-Nistune [PS13_RPS13 (SR20DET)  (Version_ 3)].png
2021-04-19 08_21_15-Nistune [PS13_RPS13 (SR20DET) (Version_ 3)].png (55.11 KiB) Viewed 346 times

kamilp1908
Posts: 12
Joined: Wed Oct 23, 2019 5:46 am

Re: Start tuning SR20DET

Post by kamilp1908 » Mon Apr 19, 2021 8:15 pm

We see about 15-16 AFR on decel, but then when you get the increase in load it seems like it takes a while for the wideband to register.
1. 15-16 AFR on decl is proper value?
2. I have LC-1 wideband is plugged in tail pipe so response can take some time. Maybe better place will be oem 02 sensor after turbo?
Do you 'feel' a lag with acceleration at this point, where it affects drivability?
It was my first drive to setup K const for cruising (with fuel cut at 3300 to avoid any boost spikes). Next time I will check response 'feel' after decel.
It's a bit strange how it goes lean, then slightly richer 14.96 (at 18.079) and then lean again before going rich
I have to analize others logs for this problem. Maybe it one time thing or some common problem with my car.
1. Does transition from lean (16-17) to rich (11.4) after gear change is ok? Maybe I need to lower throttle enrich?

PL
Posts: 938
Joined: Fri Feb 03, 2006 3:29 pm
Location: Adelaide, South Oz
Contact:

Re: Start tuning SR20DET

Post by PL » Mon Apr 19, 2021 9:31 pm

Does this cause any driveability issues? If not then I wouldn't worry about it.

Could also be something to do with AFR sensor in tailpipe. Never ideal. Best in a dedicated fitting in the down pipe.

PL

kamilp1908
Posts: 12
Joined: Wed Oct 23, 2019 5:46 am

Re: Start tuning SR20DET

Post by kamilp1908 » Mon Apr 19, 2021 9:55 pm

PL wrote:
Mon Apr 19, 2021 9:31 pm
Does this cause any driveability issues? If not then I wouldn't worry about it.

Could also be something to do with AFR sensor in tailpipe. Never ideal. Best in a dedicated fitting in the down pipe.

PL
Next logs I will make with O2 sensor in down pipe.
Thx PL.

kamilp1908
Posts: 12
Joined: Wed Oct 23, 2019 5:46 am

Re: Start tuning SR20DET

Post by kamilp1908 » Sat Apr 24, 2021 7:46 am

Matt wrote:
Mon Apr 19, 2021 9:56 am
It's a bit strange how it goes lean, then slightly richer 14.96 (at 18.079) and then lean again before going rich
I have looked in other logs, this strange lean-rich-lean behaviour occurs on every gear change (3->4, 4->5).

Matt
Site Admin
Posts: 8675
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Start tuning SR20DET

Post by Matt » Tue Apr 27, 2021 8:05 am

The ECU does a fuel cut/recover on deceleration in certain RPMs bands (not expected RPM ranges in your log) but the readings from the wideband don't really match the injection time, which is why myself and PL are both thinking there is a delay with reads, and also questioning if this affects drivability (compared to before upgrading injectors/MAF)

Post Reply