Kinugawa TD06 - 60-1/ no name z32

Results of any interesting tests done with or related to Nistune.

Moderator: Matt

Post Reply
Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Sat Feb 04, 2012 6:48 am

so i bought the said turbo and install on sr20det red
i had stock afm and was seeing 5.14v preatty much when the BOOST kicked in
long roll on it could somewhat maintain proper afr but during fast shift went lean :(
Decided to try a NoName Z32 cause im cheap also bought the apexi super intake kit cuz came with pigtail
started from a fresh map update injector and maf and bloody would barly start then stall.
had to bring K up to around 36k,
Leaned the hell out stock map and adjust load scales
was doing high 10s AFR under boost but had to go home so tuning stoped
im running 18psi cus i got the stock HG still
so far so good, will have some logs up later to see if this maf is near maxxing or whatever

Wondering if anybody have EXP with this tdo6/60-1 on sr20det
I know its a lag monster ( i know i know , but this turbo is what i got)
post some feed back people
Thanx from the great white north

Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Sun Feb 05, 2012 11:13 am

ok so in my log i have seen 4.54XV from Maf dont know till i turn up boost if this is maxed
Ive read some great posts from guys who have there Ks to a T and can command a 12.0 AFR up top and get that so i decided
to start from scratch and try my damndest to achieve this .....
my previous tunes i really didnt care about this id just throw in whatever was needed to get the AFRs i wanted, i could always get down low good but up top usually had to command say a 10.2 to get a 12 AFR ect..

so i made upper 2/3 of map read 12.0X afr and bottom third read 14.7 . Bit 5 disabled also raw value set to 0
and so it began... turn K way down to get near what i wanted up top (11.5ish) then when i come back down in TP scale peged lean
go figure .. so then i turn up inj Lat to compensate for cruising area AFR .. 1020 us latency to achieve the comanded stoich down low , got scared . Never heared any 1 running this high and i still needed to come down on k and then up on latency.
Anyone ever had there Inj latency this high or higher?

So um, am i missing something here??? know dyno or private roads around so all on road fun . Ended my public havec on
28k KCONST and 1020 us INJ LAT. im not very happy at all, should i just tune for my down low , make that all good?
then just know ill be off up top and tune to what i want on the wide band?

Or should i draw up a nice map and run AFR autotune with stock knock sr20det red, kinda thought u had to have it near good for K value n such there????

Specs
SR20DET Red
Stock feul pressure on 550s
Z32 .. i guess?
Kinugawa TD06 / 60-1
Front mount
Turbo back 3inch
18 psi boost with profec controls

Any feedback would be helpfull as i only have a few more days to play till i have to go to work
Thanks a million :) :)
Brody

Matt
Site Admin
Posts: 8219
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Matt » Tue Feb 07, 2012 10:43 am

What is the part# on the MAF. Is it a genuine unit? Should read upto 5.12v and even then it will just peg at the end of the map. So that is fine

With the 'target AFRs' dont take this in the map as what you see on the wideband. As soon as you change latency, injection mulitplier then the targets are not even close. Just work with 'Filtered view'

It is difficult to know what is going on without the BIN and LOG files. Latency appears to high and masking another issue. Would leave the maps factory until the AFRs are correct

Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Wed Feb 08, 2012 2:50 am

This thread is kinda a test on Both the said turbo and the NONAME AFM . Meter was made in USA and is a replacement one

So Yesterday fiddled a bit more then heard fuel pump struggling. i Have a aftermarket Adjustable FPR , i poped the hood and holy hell ... vacume line hooked up and over 60psi at idle. hhmmmm , hitiing bumps and/or cold weather somehow adjusted it higher or the spring was affected by cold weather big time

I also dont beileve im maxing the mass air flow meter yet as its a steady rise in voltage not just pegged over.

this cold weather stint is bugging me its 9am and -21c, its supposed to get to -10 today and if so ill go play a bit more and see if fuel pressure resolved my issue with tuneing. And if it doesnt ill post a bin and log of a couple pullls. Last day to play as work tomorrow thanx for a response matt and keep up the great work. :D

Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Wed Feb 08, 2012 6:56 am

made sure fuel preasure still good
adjust map to raw value 28 across the board
adjust k 32007 and latency 710
as u can see i was somewhat close, at 55 seconds was 4th gear let up cuz whent lean wideband said then drop down to 3k and a full pull 4th gear

next i pulled over to side of road and wiped up a very crude bin , i left the high load up top the same and adjust down low to get some close to stoich . i never touched k value or latency for this
some idle, light load, some pulls , and regular driving in this log. can only add 3 items per post see next post for this log
Attachments
base.bin
shit base thrown together side of road
(32 KiB) Downloaded 184 times
12.06_2012-02-07_1147_07.csv
goes with 12afr bin
(74.35 KiB) Downloaded 205 times
12afr.bin
(32 KiB) Downloaded 186 times

Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Wed Feb 08, 2012 6:57 am

base bin log
Attachments
base_2012-02-07_1157_00.csv
(361.42 KiB) Downloaded 149 times

PL
Posts: 909
Joined: Fri Feb 03, 2006 3:29 pm
Location: Adelaide, South Oz
Contact:

Re: Kinugawa TD06 - 60-1/ no name z32

Post by PL » Thu Feb 09, 2012 9:30 am

I've not heard any good reports about no-name Z32 AFM's but the Kinugawa turbos (in general) seem to be good. Heard only positive reports about them. Certainly good value for money.

I've got a local guy building an S14 engine with one. He bought the turbo off eBay (TD06SL2-20G for under $AU700) as well as a Tial 38mm WG. I'll post results here when he's done. Will be using Z32 AFM and most probably ID1000 injectors.

PL

Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Sat Feb 18, 2012 6:14 am

so i was having some major tuning issues and could not figure them out!
would go lean as soon as boost would hit then would go rich, i tried to tune around it with no luck
whatsoever. Looking over logs i noticed injectors where open for way to long close to 20 ms , So i decided mabey it was my FPR , changed it out to stocker and fixed the problem.

Turbo is not to bad with full spool around 4200ish, i had some fitment issues like trim engine mount just a hair and oil return tube was wayyyy to long to use factory straight soft tube to block. fabed up a 90 off drain tube a presto.

Said know NAME Z32 MAF sensor appears ok , VQmap resolution might be a bit off but nothing u cant handle
purchased from ufixit.com $70 shipped canadian. might not be a true z32 but for that price and what its doing you cant go wrong. i was maxxing the stock sr20 MAF now getting like 4.5-4.6 max atm. so i see room for more power still there

i have also been playing with virtual dyno abit (i know i know) no access to real dyno atm.

pic shows graph of VD of best i could get with shitty FPR then a safe toon on factory FPR
know knock, but any more timing and pistons want out (Knock knock, who is there)
included bin and fynal csv log that was used for virtual dyno

to get log to work with virtual dyno TPS has to be set to 100v as VD uses % for TPS

Any who, id recomend this said MAF for people on a budget , kinda wish i got the TD06 - 20G as might have been less laggy

SR20DET red
550s and stock FPR
Front mount
exhaust
clutch and light flywheel

Enjoy my shitty write up :)
Attachments
feb17_5.csv
(72.23 KiB) Downloaded 159 times
basefeb15fine.bin
(32 KiB) Downloaded 177 times
changed FPR and tune.jpg
changed FPR and tune.jpg (86.14 KiB) Viewed 5765 times

PL
Posts: 909
Joined: Fri Feb 03, 2006 3:29 pm
Location: Adelaide, South Oz
Contact:

Re: Kinugawa TD06 - 60-1/ no name z32

Post by PL » Tue Feb 21, 2012 4:23 pm

Thanks for the write-up. All feedback is good even if you think it's shitty!

Interesting about the FPR. I've seen this a lot too - people think they need an aftermarket FPR when in fact the stock one is usually just fine.

I see Kinugawa now do free shipping to Oz on eBay. Bloody good value!

Is yours 8cm or 10cm rear housing?

PL

sssbassil
Posts: 49
Joined: Sat Sep 04, 2010 8:42 pm
Location: new zealand

Re: Kinugawa TD06 - 60-1/ no name z32

Post by sssbassil » Wed Feb 22, 2012 4:39 pm

what virtual dyno are you useing thanks?

Fortmac180
Posts: 14
Joined: Fri Aug 19, 2011 7:15 am
Location: canada

Re: Kinugawa TD06 - 60-1/ no name z32

Post by Fortmac180 » Fri Feb 24, 2012 2:04 am

well i got the aftermarket FPR as i was eventually going to be running at 4 bar to make my 550s become 660cc

i would like some info on what kind of timing to be running at around 0vacum to like 3-5 pounds of boost? mabey i can spool her a bit sooner :)

i believe the rear housing is 8cm . I mean its a lag monster when compared to the stock t25, but all in all not that bad.

Virtual dyno is Brad Barnhills Virtual dyno, just google it and its free. remember u have to go into microsoft exel and change ure .CSV file before it wworks. u change from the area of the logg u want to use the TPS voltage from 4.0 (or whatever yours is at ) too 100, because it thinks its a % not a voltage. change from like 2500 to redline and it will work.

Thanks for the feedback PL, hey that customer ever get that 20g installed yet? results?

oh and i paid $830 Canadian including shipping and it showed up in 5 days from Taiwan

Post Reply