RB25DET with Z32 ECU strange enrichment on light throttle

Nistune topics related specifically to the 6303 cpu

Moderator: Matt

IceManPL
Posts: 40
Joined: Wed Apr 22, 2009 7:10 pm

RB25DET with Z32 ECU strange enrichment on light throttle

Postby IceManPL » Thu Nov 02, 2017 6:49 am

RB25 + z32 ecu, stock injectors, stock maf or 350z maf (does not matter).
When car is idling and i add a little throttle (e.g. when i try to move from stand still) AFR goes from 15 to 12 with engine at normal temp.
When engine is cold AFR goes to 10 ...
Looks like too much enrichment vs TPS. There are some enrichment maps in nistune, but they don't work :(
e.g. map called "RPM enrichment" does not matter if there is 255 or 0 still too rich. Changed other maps no difference.
My VE map is perfect, TPS set, so the problem is not there.
Log was made on 1 gear, driving at idle, and then just touched accel pedal.
Any idea ?

enrich test.csv
1 gear, enrich
(18.3 KiB) Downloaded 52 times

Eric
Posts: 224
Joined: Mon Jan 14, 2008 7:59 pm
Location: Holland
Contact:

Re: RB25DET with Z32 ECU strange enrichment on light throttle

Postby Eric » Thu Nov 02, 2017 4:00 pm

Not sure if it's the (main) cause of the problem, as you only posted a logfile and no maps, but your TPS is not set correctly...it drops to 0.26 V according to the log.
Minimum base voltage@idle for the Z32 (ECU) should be between 0.4 - 0.5 V

It seems because of the incorrectly set TPS, the Closed throttle switch doesn't work correctly either, as I see the ignition timing go all over the place, while the TPS voltage is low and closed switch flag should be on.
Closed throttle flag should be on @ idle (and obviously when the throttle is closed)...if it's not, it can cause all sorts of issues and you'll need to reset the TPS/ECU

IceManPL
Posts: 40
Joined: Wed Apr 22, 2009 7:10 pm

Re: RB25DET with Z32 ECU strange enrichment on light throttle

Postby IceManPL » Thu Nov 02, 2017 6:06 pm

TPS is set correctly.
There is no tps switch in rb25 - vq30 have one.
Closed throttle flag is on at idle, and it goes off when i move throttle just a little bit. So it is set correctly.
I have other ecu - apexi power fc - and there is no problem at all.
Ignition timing changes because rpm changes ... look at stock rb25 map.

Torque
Posts: 626
Joined: Wed Jun 16, 2010 10:08 am

Re: RB25DET with Z32 ECU strange enrichment on light throttle

Postby Torque » Thu Nov 02, 2017 11:08 pm

Hello,

There is a throttle switch on RB25, but only on Spec2.

I would not look into enrichment tables, you're not in the TPS region for enrichment.
(It kicks in much later)

Matt
Site Admin
Posts: 8038
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: RB25DET with Z32 ECU strange enrichment on light throttle

Postby Matt » Fri Nov 03, 2017 6:36 pm

You are talking about alpha/N full throttle table? There are other partial TPS enrichment done by these ecus

IceManPL
Posts: 40
Joined: Wed Apr 22, 2009 7:10 pm

Re: RB25DET with Z32 ECU strange enrichment on light throttle

Postby IceManPL » Fri Nov 03, 2017 7:08 pm

Yes i know that there are other enrichment.
Non of them works in low rpm area when i only blip throttle.
I can live with that but i like everything perfect :)


Return to “Type 2”

Who is online

Users browsing this forum: No registered users and 5 guests