Z31 warm up issues

Nistune topics specific to the 6802 cpu

Moderator: Matt

gardner86zx
Posts: 6
Joined: Sun May 25, 2008 11:35 am
Location: bennington vt

Z31 warm up issues

Postby gardner86zx » Fri Apr 28, 2017 8:52 am

86 na z31 ecu
Z32maf
750cc injectors


This has me stumped. Once warm it runs perfectly and drives great. Trying to get it to warm up it runs ok for around 30s then leans our and dies. If i and more fuel to the warm up tables it floods it out. Any help would be appreciated
Here is a Video of the issue
https://youtu.be/YoneNsITYrM

bsdkllr
Posts: 11
Joined: Wed Mar 09, 2016 5:32 am
Location: Boston, MA

Re: Z31 warm up issues

Postby bsdkllr » Fri Apr 28, 2017 11:40 pm

sounds like its suffocating. right after start up it enables the idle control valve to bring the idle up to ~1000 after 30s it shuts the idle valve and relies on the air regulator to raise the idle until it warms up and then the air regulator will close.

so either the air regulator is stuck closed or removed. or the idle speed is set a bit to low.

i dont have the air regulator on mine so if its left to idle on its own it will mostly stall until warm. i usually click the headlights on to parking or put the hvac fan on. both with engage the idle control valve and raise the idle.

Matt
Site Admin
Posts: 7649
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Z31 warm up issues

Postby Matt » Sat Apr 29, 2017 9:34 am

When switching to Z32 MAF on these earlier ECUs I've noticed the movement of the load indexing (TP) can affect startup fueling. See the same thing on the RB30 ECUs which use the same firmware as the Z31 VG30

What you need to do is adjust the Warm/Cold enrichmnent tables to add more fuel upto the 60degC mark. The AFRs need to be richer when it is colder so about 13:1 range when it is cold would be a good start and ramp that down to 14.7:1 once it starts getting warmer


Return to “Type 1”

Who is online

Users browsing this forum: No registered users and 5 guests