Auto AFR bug - wideband freeze when Auto AFR is open

Discuss software bugs and related problems here.

Moderator: Matt

Post Reply
mike2016
Posts: 10
Joined: Sat Dec 15, 2018 10:59 pm

Auto AFR bug - wideband freeze when Auto AFR is open

Post by mike2016 » Wed Jan 02, 2019 4:53 pm

Type-2 board
Car - BNR32 RB26
Laptop - Lenovo X1 / Windows 10 Pro
Wideband - Innonvate LM-2
Nistune and LM-2 are connected to laptop with their own USB ports.


When Auto AFR window or AFR grapher is open, wideband reading will freeze in Nistune, but it's still reporting "wideband connected".
If I click "disconnect" button, the message "Disconnecting from wideband....." stays and won't go away.
I have to restart Nistune for wideband to work again.

Other functions work properly such as Input tracer , data logging....etc without issues.

Only when I open Auto AFR or AFR grapher, wideband stops working.

Wideband itself on LM-2 handheld is functioning properly.

Matt
Site Admin
Posts: 8176
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Auto AFR bug - wideband freeze when Auto AFR is open

Post by Matt » Thu Jan 03, 2019 11:50 am

Managed to identify the issue (caused by array overrun in 1.2.88 version). Will put a release out today

mike2016
Posts: 10
Joined: Sat Dec 15, 2018 10:59 pm

Re: Auto AFR bug - wideband freeze when Auto AFR is open

Post by mike2016 » Thu Jan 03, 2019 8:26 pm

Great! Will test it out

Thanks Matt for the quick action

wilsonthesphere
Posts: 4
Joined: Sun Sep 02, 2018 4:30 am
Location: Miami, FL

Re: Auto AFR bug - wideband freeze when Auto AFR is open

Post by wilsonthesphere » Sat Jan 19, 2019 10:53 am

I have the same exact same issue for the
Type 1 board
Z31
LC-1 wideband

Should the fix also apply to the type 1 board?

Thanks

Juan

Matt
Site Admin
Posts: 8176
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Auto AFR bug - wideband freeze when Auto AFR is open

Post by Matt » Mon Jan 21, 2019 11:36 pm

Yes its already fixed in the 1.2.103 version.

wilsonthesphere
Posts: 4
Joined: Sun Sep 02, 2018 4:30 am
Location: Miami, FL

Re: Auto AFR bug - wideband freeze when Auto AFR is open

Post by wilsonthesphere » Tue Jan 22, 2019 3:00 am

Thank you Matt

Post Reply