VQ30det jetboat

Discuss hardware problems here.

Moderator: Matt

jetdesignco
Posts: 4
Joined: Sat Jan 13, 2018 7:35 pm

VQ30det jetboat

Postby jetdesignco » Sun Jan 14, 2018 1:48 pm

[img]https://lh3.googleusercontent.com/2E_FIKQsYpPt2ItSwMakZaI-sRlRMCuLIkzjyMcKpCJ_XUKA9QzwyhvXxiK-ibJU_HY_6A=s114
[/img]I have a small jetboat with a VQ30det installed
all was well until I tried for "A bit more boost" to achieve this I installed 580cc injectors (Flow tested at 620cc) and "Spit fire coils"
the turbo is already an after market garret "Nock off"

The project sat still for a long time as I have started Jetsprint racing and have a V8chev
long story short we had a sudden rush of shit to the brains and decided to get the old river boat running

Our tuning was going OK till my laptop ran out of power then a Saturday call to Matt got us running on my tuners laptop "Thanks Matt"
our tune was ok till we tried to "Burn" then all hell let loose
Rich Rich Rich
we tried all sorts of different angles to get around the problem
several sets of plugs later we are no further ahead
I suspect a faulty TPS?, as the Rich happens after a big throttle movement
maybe the TPS still shows 5v at idle?
I will check this next during the week ahead

Any ideas?

By the way
My tuner is used to LINK and wonders if negative values made available on the fuel map cells might be a good idea?

Matt
Site Admin
Posts: 7859
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: VQ30det jetboat

Postby Matt » Mon Jan 15, 2018 12:22 pm

Something went wrong at the time of the burn as you mentioned

After burn on some ECUs (Y33 might be one of them) it is necessary to power off the ECU completely (to power cycle the ECU program) and then start up again

It may be that not doing this has corrupted the ECU program, since it is at this point you were seeing issues.

However I need a tune file and log file to look over changes to see if any other issue.

At this stage the board might need a reflash to put the original program back in there

jetdesignco
Posts: 4
Joined: Sat Jan 13, 2018 7:35 pm

Re: VQ30det jetboat

Postby jetdesignco » Mon Jan 15, 2018 4:52 pm

Thanks Matt

How do I re flash the ECU?

Matt
Site Admin
Posts: 7859
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: VQ30det jetboat

Postby Matt » Tue Jan 16, 2018 11:09 pm

Base image programmer is required for reflashing the board.
http://nistune.com/docs/Base_Image_Programmer_Manual.pdf

You could try closest workshop here:
https://www.nistune.com/workshops/australia/new-zealand

I got your voicemail, but dont dial out international numbers. Above info is what you need, or email / call me again. I can also program the board here if you send the ECU

jetdesignco
Posts: 4
Joined: Sat Jan 13, 2018 7:35 pm

Re: VQ30det jetboat

Postby jetdesignco » Sun Feb 11, 2018 10:19 am

Great news
Thanks Matt for the quick turn around on the computer check
All seems good now
We ran the boat yesterday under its own power, on our base tune
Next the real deal

I have some homework in between sessions
Check all injector seat seals (new seal kit)
Small issue on start up with leak on number 6

Still have the excellerator "cough" off idle ( will get logs to you Matt)
Tuner is trying to find acceleration enrichment table?
We have lots of fuel up top now due to the large injectors
(Flowed at 620cc) so map trim next session

New firmware looks great
Lots of extras?

Engine sounds happy at idle now

Matt
Site Admin
Posts: 7859
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: VQ30det jetboat

Postby Matt » Mon Feb 12, 2018 1:54 pm

There is only the 'VE map' used for acceleration enrichment. It is TPS vs RPM

However, is there a boost sensor connected. Is it connected properly?

More info on this table in our 'mapping' document and NEO tuning guide:
http://nistune.com/docs/Nistune%20NEO%20ECU%20Tuning.pdf


Return to “Hardware Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest