300zx bluetooth issue

Discuss hardware problems here.

Moderator: Matt

Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

300zx bluetooth issue

Postby Bird » Fri Feb 13, 2015 7:38 am

Hi everyone,
I'm new here and found the forum when looking to find a solution to a nicking problem. This seemed like a place that might be able to answer my query.

I have a Nistuned ecu (daughter board in there). The car connects fine to datascan/ecutalk etc without any problems. I recently bought the track electronics bluetooth adapter and although the bluetooth connects to my phone, I always get ini failed error and so can't read any data via this method.

Does anyone know if this is because of the ecu/nistune board not allowing it? If so, is there a way to fix it?

Many thanks,
Lee

Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

Re: 300zx bluetooth issue

Postby Bird » Sat Feb 14, 2015 5:46 am

Anyone?

Matt
Site Admin
Posts: 7662
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: 300zx bluetooth issue

Postby Matt » Sun Feb 15, 2015 8:57 pm

Had Friday off...

Bluetooth wont work with Nistune due to latency issues (small data packets back/forth) with the bluetooth design which uses large packets (so will only work fine in 'stream mode' in Nistune)

Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

Re: 300zx bluetooth issue

Postby Bird » Sun Feb 15, 2015 9:45 pm

Thanks Matt,
So is it impossible to fix then? When you say stream mode, do you meant plugged in to the Laptop?

I don't actually have the nistune software on my Laptop but the other thing I noticed in the likes of datascan is that it won't let me view the maps and things. Is this also correct or could it be that the map was locked down by the mapper?

Matt
Site Admin
Posts: 7662
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: 300zx bluetooth issue

Postby Matt » Mon Feb 16, 2015 10:09 am

Nistune maps cannot be downloaded in Nissan datascan due to the changes in PIN locking used on the boards and different memory read commands

This thread covers why bluetooth cannot be used with Nistune:
http://forum.nistune.com/viewtopic.php?f=4&t=2329

Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

Re: 300zx bluetooth issue

Postby Bird » Mon Feb 16, 2015 10:40 am

Sorry if I'm missing something here but I don't see where the thread explains why bluetooth doesn't work.

It's not for tuning purposes or anything I'm wanting, just the ability to read fault codes etc like what's offered on ndsi for android



This thread suggested that it works with the trackelectronics adapter too

Matt
Site Admin
Posts: 7662
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: 300zx bluetooth issue

Postby Matt » Mon Feb 16, 2015 4:55 pm


Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

Re: 300zx bluetooth issue

Postby Bird » Tue Feb 17, 2015 3:32 am

I've had a read through it and most of it completely baffled me. Unless I'm reading it wrong though it suggests that bluetooth is possible, just stupily slow 'latency' issues. Might be a difference between the skyline and the 300zx though.

Thing is, I'm not really looking for any Nistune specific data, just the general ECU stuff like error codes, AAC value etc.

skylinegtrhr
Posts: 291
Joined: Sat Jun 21, 2008 1:50 am
Location: Croatia
Contact:

Re: 300zx bluetooth issue

Postby skylinegtrhr » Tue Feb 17, 2015 5:30 am

Bird wrote:
It's not for tuning purposes or anything I'm wanting, just the ability to read fault codes etc like what's offered on ndsi for android

This thread suggested that it works with the trackelectronics adapter too


I use NDSI for android and track electronic adapter for that without problem even on diesel cars( and on z32 also),
can you connect it when engine is not running only ign is on? Maybe ground problem and it is making a lot of "noise"?

Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

Re: 300zx bluetooth issue

Postby Bird » Tue Feb 17, 2015 9:27 am

skylinegtrhr wrote:
Bird wrote:
It's not for tuning purposes or anything I'm wanting, just the ability to read fault codes etc like what's offered on ndsi for android

This thread suggested that it works with the trackelectronics adapter too


I use NDSI for android and track electronic adapter for that without problem even on diesel cars( and on z32 also),
can you connect it when engine is not running only ign is on? Maybe ground problem and it is making a lot of "noise"?


Thanks for that. Did the cars have a nistune ecu (proper daughter board) or just a chip tuned using nistune?

Also, sorry to sound thick but what do you mean by a ground problem?

Thanks a bunch
Lee

skylinegtrhr
Posts: 291
Joined: Sat Jun 21, 2008 1:50 am
Location: Croatia
Contact:

Re: 300zx bluetooth issue

Postby skylinegtrhr » Tue Feb 17, 2015 7:09 pm

Hi Lee
Nistune board is on all tested cars, that diesel of course not :)

Electric ground problem, you can find a lot about it on this forum ... but if it can't connect even when engine is not working then it is probably something else ...

Bird
Posts: 8
Joined: Wed Feb 11, 2015 7:48 am
Location: Sunderland, UK

Re: 300zx bluetooth issue

Postby Bird » Tue Feb 17, 2015 7:34 pm

skylinegtrhr wrote:Hi Lee
Nistune board is on all tested cars, that diesel of course not :)

Electric ground problem, you can find a lot about it on this forum ... but if it can't connect even when engine is not working then it is probably something else ...


I always get the 'INI FAILED' error in NDSI

RJBijsterbosch
Posts: 28
Joined: Sat May 20, 2017 1:35 am

Re: 300zx bluetooth issue

Postby RJBijsterbosch » Sun Sep 17, 2017 4:21 pm

I also had this problem with ini failed. I got a bleutooth adapter from OBD Innovations. Although the adapter was recommanded on the Nissan datascan website it was a faulty one. Tom didn't know, that these one's were faulty. Together with Tom we've found out that the CLK signal on the adapter was missing @ the correct pin, because of a fault on the PCB. Soldered a extra wire, to get the CLK signal to the correct pin and the adapter worked.

You can see what i have done on the Nissan data scan forum.

Check this post: Nissan DataScan I for Android: Ini Failed skyline r33 gtst z32 (EU) ecu nistune "solved" ( can not get a direct link?)

I also mailed to OBD innovations that they were selling faulty adapters. And they asked how i repaired the adapter, because they did not know what the problem was. Because of my help, I asked if they can send me a new adapter if they had solved the problem. Still waiting for a new one, and they don't reply to my emails anymore. :twisted:

But mine is still working. :D

I have a Android car stereo in my Skyline and can connect the BT Adapter to my Phone with NDS app and than by Mirror Link. I can show the data on the screen of my stereo, this way. Very nice feature. :D


Return to “Hardware Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest