S14 SR20DET rich throttle / idle recovery

Discussions concerning the M7790 cpu

Moderator: Matt

stuffcc
Posts: 14
Joined: Sun Mar 01, 2015 5:29 am
Contact:

S14 SR20DET rich throttle / idle recovery

Postby stuffcc » Sat Sep 08, 2018 5:33 am

Hello,

I'm having trouble with my S14 SR20DET where it goes rich (10-10.5) when I blip the throttle (just a hair) starting from idle, when in neutral. I can hear/feel the engine bog because the AFR isn't right, I tried zeroing the throttle enrichment tables and few other ones without success. Tried the stock throttle body and a Z32 MAF without success.

Also, it doesn't goes back down to idle properly, if i go past ~2000rpm and let the throttle go, it'll stall, I have to assist with throttle to bring the rpm down slowly, even sometimes it doesn't help and I have to repeat this a few times to make it catch idle but it could be because of the first problem.
I see that the TPS idle box is red, set at 0.46-0.48V. I tried another FICD/AAC valves without changes.

I checked for air leaks, none from the turbo inlet to the engine. Tried to start fresh with a base tune with injectors/MAF changed only.
If I remove the air filter, it goes pig rich and stall.

Main specs :
75F00 ECU FP1
HPX N1 3" tube Z32 load
Bigger turbo
FMIC
SR20DE throttle body, cold starter removed
740cc nismo injectors
Vented BOV
BC stage 2 cams
9,04:1 CR
Timing synchronised with ECU
HKS mushroom filter

I can post the full engine specs but I don't think it really matter.
Can post logs if needed (precise what constant to select)...
Can't remember when these problems appeared as it’s been a long time since it was running (engine rebuild) but it was already there before.
Last edited by stuffcc on Sat Sep 08, 2018 6:03 am, edited 1 time in total.

Matt
Site Admin
Posts: 8046
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: S14 SR20DET rich throttle / idle recovery

Postby Matt » Sat Sep 08, 2018 5:41 am

If you run the vehicle at cruise, are your mixtures stoich with near 0% trim (STFT/LTFT?)

Take logs showing full throttle run through the fuel map, cruise and then when you accelerate showing the problem. Keep the logs short and post with your tune file

louiswun
Posts: 222
Joined: Tue Apr 07, 2009 1:11 am
Location: Hong Kong

Re: S14 SR20DET rich throttle / idle recovery

Postby louiswun » Sat Oct 06, 2018 2:50 am

I'm 100% sure it is throttle enrichment not tuning right with the 740cc injectors.
I used to have same issue with 740cc, but now, I know how to tune right.
Please note that I'm using standard ENT files, not Feature Pack base.
Here is the result, transplant some of the maps from S15 91F08 ECU , scale it down to suit 740cc injectors.
https://www.youtube.com/watch?v=modt7mZwRok
This is S13 SR20DET Type X ECU, more maps needs to adjust compare between S14/S15 maps.

Edit :
For the S13 Type X in the video, other than the 4 maps mention in the reply, the following maps also need to copy from S15
Throttle Movement Temp
Throttle Movement RPM
Throttle Correction RPM
Async Temp Factor
Sync Temp Factor
Sync RPM Factor
Sync Rate Factor
Decel Loss RPM
Decel Loss Temp
Decel TPS Max
Last edited by louiswun on Sat Oct 06, 2018 4:44 am, edited 5 times in total.

louiswun
Posts: 222
Joined: Tue Apr 07, 2009 1:11 am
Location: Hong Kong

Re: S14 SR20DET rich throttle / idle recovery

Postby louiswun » Sat Oct 06, 2018 2:59 am

Your vented BOV causing idle recovery problem.
ditch it and change to recirculate type BOV, idle recovery problem sloved.

louiswun
Posts: 222
Joined: Tue Apr 07, 2009 1:11 am
Location: Hong Kong

Re: S14 SR20DET rich throttle / idle recovery

Postby louiswun » Sat Oct 06, 2018 3:23 am

In the Throttle Enrichment,
If target tune is for S14 ECU.
Only 4 maps need to adjust.

Copy the following maps data from S15 91F08 ecu
Async MAF Factor
Decel Loss MAF

Scale down the following maps by injector size
Async TPS Factor
Async TPS Cut Factor

Example for Async TPS Factor
S15 91F08 ECU 107 80 62 47 13 0 0 0 (just treat it as 444cc injectors)
S14 69F00 ECU 128 96 74 49 16 0 0 0 (370cc injectors)
S14 or S15 ECU 64 48 37 25 8 0 0 0 (740cc injectors only require half of the duration from 370cc injectors for same effect)
S14 or S15 ECU 86 65 50 33 11 0 0 0 (Same principle, but for 550cc injectors)
Last edited by louiswun on Sat Oct 06, 2018 4:45 am, edited 4 times in total.

louiswun
Posts: 222
Joined: Tue Apr 07, 2009 1:11 am
Location: Hong Kong

Re: S14 SR20DET rich throttle / idle recovery

Postby louiswun » Sat Oct 06, 2018 3:49 am

Here is my own S14 Zenki throttle enrichment, hear the difference between S14 and S15 factory tune on same engine same cat back.

100% factory tune untouch , fully warm up (Hear the popping ?? please note that still using DET smaller throttle boby)
https://youtu.be/W-vjfMNx7ZY

S14 JDM Zenki ECU with Nistune, Factory Cat, DET smaller throttle body, S15 throttle enrichment (Sounds Cleaner)
https://youtu.be/wWWdZwLq2Sw

Added NA SR20DE 60mm throttle body and HKS 256 cams, Factory Cat
https://youtu.be/jjokhughkE4

Added 5" 100 CPI High Flow Cat, 3 minutes after cold start, O2 feed back just start, idle around 14.7 AFR (Sounds crispy)
https://youtu.be/0sQ7RwavZuQ
Last edited by louiswun on Sat Oct 06, 2018 4:48 am, edited 3 times in total.

louiswun
Posts: 222
Joined: Tue Apr 07, 2009 1:11 am
Location: Hong Kong

Re: S14 SR20DET rich throttle / idle recovery

Postby louiswun » Sat Oct 06, 2018 4:16 am

Although I'm still using factory 370cc injecors on my own car,
But all of my customer's SR, usually change to 740cc injectors, it works fine on both S13 SR20DET early model and late model.
Same method also works fine on CA18DET engine control with S14 early model ECU + GTR35 injectors.
It sounds good and better engine response than using CA18DET ecu.

stuffcc
Posts: 14
Joined: Sun Mar 01, 2015 5:29 am
Contact:

Re: S14 SR20DET rich throttle / idle recovery

Postby stuffcc » Sat Oct 06, 2018 11:02 pm

Well, that's some infos ! Thanks !

I didn't give any updates since, been busy with other stuff but I did play with K, MAF scaling etc, I took some data with my ecu on a friend's S14 (stock engine, injectors, MAF, turbo, cams, throttle body) to see how it is running to have a reference for mine.

I'll record logs, post the tune, take some videos and try your settings, but even by zeroing the enrichment maps, it still goes very rich when giving a hair of throttle and when driving it's not smooth on the very first throttle % because of the AFR's going too rich.

Also, new issue since the temps went down recently (maybe a coincidence), it's very difficult to do a cold start, I have to play with the crank enrichments to eventually be able to start it.

I'm planning on switching for a standalone ECU anyway, but I want to find what's going wrong first. I'll report some update when I'll be able to work on it.


Return to “Type 3/4/5”

Who is online

Users browsing this forum: No registered users and 5 guests