Help with S13 SR20 Tune

Discussions concerning the M7790 cpu

Moderator: Matt

spencerm
Posts: 4
Joined: Tue Aug 23, 2016 12:50 am

Help with S13 SR20 Tune

Postby spencerm » Wed Aug 24, 2016 10:59 pm

Hi Guys,

I just finished a motor rebuild and am having a bit of a problem with my tune. Motor specs:

S13 SR20det
JWT S4 cams
Z32 MAF
ID1000

I can sometimes get the car to start up and have a rough idle when the TIM it turned up very high (close to max). This results in a very rich and rough idle. Anytime the TIM is lowered less than close to max I cannot get the car to start.
Attached is the tune I’m working with so far and a log of trying to start the car.

Any help is greatly appreciated.
Attachments
new 8-22.bin
(32 KiB) Downloaded 57 times
NIStune_2016-08-22_1833_47.csv
(19.97 KiB) Downloaded 39 times

Lok
Posts: 5
Joined: Sun Aug 21, 2016 9:14 am

Re: Help with S13 SR20 Tune

Postby Lok » Wed Aug 24, 2016 11:40 pm

Try adjusting the latency first to get it idle when you first start it.

I use the plus key and have the auto box checked so it applies the change on the fly.

spencerm
Posts: 4
Joined: Tue Aug 23, 2016 12:50 am

Re: Help with S13 SR20 Tune

Postby spencerm » Thu Aug 25, 2016 6:43 am

I've messed with the latency also, the most I can get it to do is a rich "stumble" idle.

Is there anything else I should be looking into? I've read through most of the nistune documentation and I'm at a bit of a loss.

Lok
Posts: 5
Joined: Sun Aug 21, 2016 9:14 am

Re: Help with S13 SR20 Tune

Postby Lok » Thu Aug 25, 2016 8:10 am

Can you get the car to run in stock form minus the cams?

spencerm
Posts: 4
Joined: Tue Aug 23, 2016 12:50 am

Re: Help with S13 SR20 Tune

Postby spencerm » Thu Aug 25, 2016 8:25 am

I can't. It's a completely different setup and I do not have those parts anymore. Built bottom end, built head, new turbo.

Lok
Posts: 5
Joined: Sun Aug 21, 2016 9:14 am

Re: Help with S13 SR20 Tune

Postby Lok » Thu Aug 25, 2016 8:34 am

I was just referring to stock injectors and maf(sohc)

Some way of confirming correct base time etc.

spencerm
Posts: 4
Joined: Tue Aug 23, 2016 12:50 am

Re: Help with S13 SR20 Tune

Postby spencerm » Thu Aug 25, 2016 8:38 am

Yeah, I'm afraid I don't have that either. Timing should be correct, I followed the timing procedure documented here: http://www.frsport.com/How-To-Set-Crank-Angle-Sensor--CAS--Timing-on-the-SR20DET-Engine_t_25.html

Matt
Site Admin
Posts: 7955
Joined: Sun Jan 29, 2006 1:45 am
Location: Adelaide, Australia
Contact:

Re: Help with S13 SR20 Tune

Postby Matt » Fri Aug 26, 2016 9:44 am

With the base timing:

Disconnect the TPS connector

Operations > Active tests > Set the timing parameter to a value (say 20 deg BDTC) and start the test
Check that the timing mark on the crank (using timing light) is matching 20 deg BDTC. This test fixes the timing to set value

After this stop the test. Check where timing is sitting inside Nistune (eg 15 deg BDTC) and check also matchng still with timing light.

If the value is off, then adjust the distributor/CAS until it lines up

With the base fueling, adjust K constant/TIM until good AFRs 14.7:1 on light cruise. With idle adjustment only use the injector latency to set to value of factory injectors, you can use TP min table to help stabilise minimum load which can affect injection at idle


Return to “Type 3/4/5”

Who is online

Users browsing this forum: No registered users and 3 guests